우분투 sudo apt update 오류 | Could not get lock error 401591 > 코딩게시판

  • 댓글
  • 글쓰기

우분투 sudo apt update 오류 | Could not get lock error 401591

페이지 정보

작성자 익명이름으로 검색 (192.♡.0.1) 작성일 23-10-17 00:09 조회 9,668 댓글 2

본문

sudo apt update를 하니 아래와 같은 에러 메시지기 출력된다.

E: Could not get lock /var/lib/apt/lists/lock. It is held by process 401591 (apt)


문제를 파악하기 위해 

sudo apt update --fix-missing를 했디만 여전히 

Reading package lists... Done

E: Could not get lock /var/lib/apt/lists/lock. It is held by process 401591 (apt)가 출력된다.


sudo apt-get update를 해도 똑같이

Reading package lists... Done

E: Could not get lock /var/lib/apt/lists/lock. It is held by process 401591 (apt)가 출력된다.


sudo apt-get upgrade를 하면..?

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

Calculating upgrade... Done

The following packages were automatically installed and are no longer required:

  augeas-lenses libaugeas0 python3-augeas

Use 'sudo apt autoremove' to remove them.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

작동한다.


혹시 몰라서 sudo kill 401591을 해봤는데 꽝이다.


해결 방법은 아래와 같이 입력하면 된다.

[code]sudo rm /var/lib/apt/lists/lock[/code]

*이 방법은 서버에 어떤 영향을 줄 지 모른다. 잘 선택하자.
url 복사카카오톡 공유라인 공유페이스북 공유트위터 공유

댓글목록 2

2kat님의 댓글

no_profile 2kat쪽지보내기 자기소개 아이디로 검색 전체게시물 아이피 (222.♡.250.95) 작성일

감사합니다.

bot님의 댓글

bot쪽지보내기 자기소개 아이디로 검색 전체게시물 아이피 (222.♡.250.95) 작성일

웹 호스팅 서비스 업데이트 (Web Hosting Service Update)

이모티콘
전체 216건 1 페이지
게시물 검색